Google not indexing (not a new site)

This forum is for discussion of Google only. Post anything Google here, including news and SEO related questions.
mko

Google not indexing (not a new site)

Postby mko » Sun Apr 02, 2006 1:39 am

Hi,

This site is running for couple of years now and it had PR5. Previous owner did not pay enough attention to SEO and he only used adwords and ppc programs to boost site traffic. I could not say if it came suddenly or not, but after some time the site got PR0 and when trying to see what pages are indexed by google I see a number of 4-129.
That is at least strange because google should index at least 30,000 pages that this site generates. I am not sure how to check when is the last time google tried to index the site, how long does it take for google to re-index the site again, and most important why this site did not get indexed in full. If you would like to check it out yourself it is galileo.hr. The only thing not common is that site uses url rewrite, ie. concatinates query string in address body, which I believe is not a prolem for google.
I would like to hear you opinion.

Thanks

trickytree

Re: Google not indexing (not a new site)

Postby trickytree » Sun Apr 02, 2006 8:23 am

mko wrote:www. galileo. hr




:wink:

coop99
Posts: 163
Joined: Sat Jul 30, 2005 2:43 am
Location: Seattle, WA
Contact:

Postby coop99 » Sun Apr 02, 2006 9:50 pm

There is no site at that url to check. Post the site and we can help answer your questions easier.

mko

Postby mko » Mon Apr 03, 2006 2:17 am

this is a valid url www.galileo.hr

coop99
Posts: 163
Joined: Sat Jul 30, 2005 2:43 am
Location: Seattle, WA
Contact:

Postby coop99 » Mon Apr 03, 2006 9:46 am

The index page is listed in Google:

http://www.google.com/search?hl=en&lr=& ... ileo.hr%2F

There are other pages of your site indexed already:

http://www.google.com/search?hl=en&lr=& ... galileo.hr

When I click on the link above it directs me to this page as the index:

/home__cro.aspx

also these pages look indexed like the home page

/home_eng.aspx
/home.aspx

It appears that your linking and site directory structure needs some work or tweaking. Certain urls may need to be redirected to the main url.

Intelligent navigation is very important if you hope to have pages found and indexed properly. See if MSN and Yahoo are having trouble too.

Did you change web sites recently and urls?

Maybe research 301 redirects and canonical urls


Return to “Google”

Who is online

Users browsing this forum: No registered users and 1 guest