coop99 and Admin,
Thank you so much for your help!
I also think it should be Mod_rewrite problem on my new hosting server. My site is hosted on an open source CMS system "Joomla" with SEF (search engine friendly URL through Appache Mod_rewrite) function. When the SEF is turned off, it's no problem using the Meta Tag Analyzer Tool. But when SEF is turned on, I get 404 error.
I also contacted my hosting company for help. They think it's the problem from Meta Tag Analyzer. Following is their response:
----------------------------------------------------------------------
We have checked and found out that you are using SEO SEF URLs in the Mambo application. The issue you are facing could be related to them.
Please, provide us with URLs you have used and they returned 404 errors in order to check further.
>>2006-02-13 08:06am by guidebuy - I used "
http://www.guidebuy.com" and "
http://www.guidebuy.com/index.php". Both returned 404 error.
2006-02-13 08:23am by dave -
This is odd. We have checked your site with the provided tool and here is what we got first time:
---[quote]--------------
META TAG ANALYZER
Click here to check you have used the correct keywords in your website.
Status.
Status: 200 OK
Web Server: Apache/1.3.34 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_ssl/2.8.25 OpenSSL/0.9.7a PHP-CGI/0.1b
Content: text/html, text/html; charset=iso-8859-1
Meta tags report for:
http://www.guidebuy.com/
meta tag length value
Title: 46 GuideBuy - Your One Stop Online Shopping Guide
........
........
........
---[quote]-------------------
We have not specified spider option.
The odd is that we have tried again and we also got:
Error: 404 Not Found
message.
Then we have turned off SEO SEF URLs and every URL we have submitted for your site have been analyzed.
We have left the SEO SEF URL turned off. Please, check now and give us feedback.
Best Regards,
Dave
Support Team Supervisor
Siteground.com
>>2006-02-13 08:41am by guidebuy - Thanks so much, Dave!
It's ok with SEF turned off.
Is it the Meta Tag Analyzer problem or Joomla SEF bug? I also think it's very odd.
Michael
2006-02-13 08:47am by dave - This issue could be related to the analyzer - it seems that it cannot follow mod_rewrite rules application is using to create URLs.
Once you are done with the meta tag analysis tool, you can enable the SEO SEF URLs again.
If you need any further assistance, do not hesitate to contact us again.
Best Regards,
Dave
Support Team Supervisor
Siteground.com
2006-02-13 08:48am by guidebuy - But I need SEF turned on. That is a key reason why I move to joomla host with Mod rewrite. or is it possible the Mod rewrite problem?
2006-02-13 08:50am by dave - It is the tool - if you supply a full URL (when the SEO SEF is enabled) it will parse it, but for some reason the tool cannot load main page.
Once you are done with the meta tag analysis tool, you can enable the SEO SEF URLs again.
If you need any further assistance, do not hesitate to contact us again.
Best Regards,
Dave
Support Team Supervisor
Siteground.com
-------------------------------------------------------------------------------------